45 lines
1,020 B
Nix
45 lines
1,020 B
Nix
{
|
|
description = "Flake for the contents of https://zerforschen.plus";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-24.11";
|
|
};
|
|
|
|
outputs =
|
|
{ self, nixpkgs }:
|
|
let
|
|
supported-systems = [
|
|
"x86_64-linux"
|
|
"aarch64-linux"
|
|
];
|
|
forAllSystems =
|
|
f:
|
|
nixpkgs.lib.genAttrs supported-systems (
|
|
system:
|
|
f rec {
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
inherit system;
|
|
}
|
|
);
|
|
in
|
|
{
|
|
packages = forAllSystems (import ./packages.nix);
|
|
|
|
devShells = forAllSystems (
|
|
{ pkgs, system, ... }:
|
|
{
|
|
default = pkgs.mkShellNoCC rec {
|
|
inputsFrom = [ self.packages.${system}.default ];
|
|
|
|
shellHook = ''
|
|
mkdir -p themes
|
|
ln -snf "${self.packages.${system}.hugo-theme-poison}" themes/poison
|
|
'';
|
|
};
|
|
}
|
|
);
|
|
|
|
formatter = forAllSystems ({ pkgs, ... }: pkgs.nixfmt-rfc-style);
|
|
};
|
|
}
|