mirror of
https://github.com/kaesaecracker/nixos-configuration.git
synced 2025-01-18 02:20:14 +01:00
24 lines
439 B
Nix
24 lines
439 B
Nix
_: {
|
|
config = {
|
|
services.openssh = {
|
|
enable = true;
|
|
openFirewall = true;
|
|
settings = {
|
|
PermitRootLogin = "without-password";
|
|
PasswordAuthentication = false;
|
|
KbdInteractiveAuthentication = false;
|
|
};
|
|
};
|
|
|
|
services.tailscale = {
|
|
enable = true;
|
|
openFirewall = true;
|
|
};
|
|
|
|
networking.firewall = {
|
|
enable = true;
|
|
checkReversePath = "loose";
|
|
};
|
|
};
|
|
}
|