servicepoint-binding-uniffi/flake.nix
Vinzenz Schroeter c6d2ee6fe1
Some checks failed
Rust / build (push) Failing after 2m20s
remove libraries as they will also move to separate repositories
2025-02-16 13:21:25 +01:00

61 lines
1.3 KiB
Nix

{
description = "Flake for the servicepoint library.";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-24.11";
};
outputs =
inputs@{
self,
nixpkgs,
}:
let
lib = nixpkgs.lib;
supported-systems = [
"x86_64-linux"
"aarch64-linux"
"aarch64-darwin"
"x86_64-darwin"
];
forAllSystems =
f:
lib.genAttrs supported-systems (
system:
f rec {
pkgs = nixpkgs.legacyPackages.${system};
inherit system;
}
);
in
rec {
devShells = forAllSystems (
{ pkgs, system }:
{
default = pkgs.mkShell rec {
packages = with pkgs; [
(pkgs.symlinkJoin {
name = "rust-toolchain";
paths = with pkgs; [
rustc
cargo
rustPlatform.rustcSrc
rustfmt
clippy
cargo-expand
cargo-tarpaulin
];
})
xe
xz
pkg-config
];
RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
};
}
);
formatter = forAllSystems ({ pkgs, ... }: pkgs.nixfmt-rfc-style);
};
}